Wprowadzenie

Program Hartley służy do wyznaczenia funkcji regresji w postaci wielomianu drugiego stopnia, dla przypadku planów eksperymentalnych trój-poziomowych. Plany trój-poziomowe, czyli takie, w których czynniki wejściowe (w liczbie k) przybierają wartości na trzech poziomach zmienności, umożliwiają uzyskanie modelu matematycznego badanego procesu w postaci wielomianu drugiego stopnia [1]:

wygodnej do analizy matematycznej i badań modelowych. Model kwadratowy powinien być stosowany do opisu obszaru zawierającego ekstremum badanej funkcji (punkt stacjonarny badanego procesu). Takie procesy, w których przybliżenie liniowe jest nieadekwatne, znacznie lepiej można opisywać adekwatnymi zależnościami drugiego stopnia, a czynniki wejściowe powinny przyjmować wartości na trzech poziomach zmienności.

W planach trój-poziomowych dokonuje się kodowania czynników zmiennych, budowy matryc planowania i matematycznej obróbki wyników badań.

Program realizuje całość zagadnienia. Posiada instalator, pomoc oraz stronę internetową ( https://plany.programy-mm.pl ), skąd można pobrać wersję instalacyjną. Program można uruchamiać na dowolnym systemie operacyjnym Windows.

W dalszej części pomocy omówiono dość szczegółowo, z ilustracjami graficznymi, opcje programu.

[1] Korzyński M.: Metodyka eksperymentu. Planowanie, realizacja i statystyczne opracowanie wyników eksperymentów technologicznych. Wydawnictwo WNT, Warszawa.

Copyright © 2023 Marek Martyna. All Rights Reserved.


Instalacja

Program Hartley instalowany jest za pomocą specjalnego instalatora w postaci pliku wykonywalnego Hartley_inst.exe. Na początku użytkownik jest proszony o wpisanie klucza do programu. Jeśli klucz jest poprawny, to rozpoczyna się proces instalacji.

Instalacja może przebiegać w języku angielskim lub polskim. Program instalacyjny wykrywa wersję językową systemu operacyjnego i jeśli jest to język polski, to uruchamia się po polsku a w przypadku każdego innego języka, w języku angielskim. Poniżej przedstawiono wybrane okienka dialogowe programu instalacyjnego.

Jedno z okienek pokazane poniżej jest istotne z punktu widzenia systemów operacyjnych 64 bitowych. W przypadku systemów 32 bitowych nie ma ono znaczenia.

Kolejne okienko zawiera umowę licencyjną.

Niektóre okienka dialogowe zawierają również linki do strony internetowej programu lub poczty e-mail. Poniżej pokazano okno 'Opcje instalacji'.

Ostatnie okienko dialogowe umożliwia uruchomienie programu zaraz po instalacji.

Jeśli zaznaczone zostanie pole 'Uruchom aplikację', program uruchomi się i na ekranie pojawi się okienko powitalne.

Program instalacyjny umieszcza ikonkę programu Hartley na pulpicie, z którego można program uruchomić. Program instaluje również w systemie trzy skróty umożliwiające: uruchomienie programu, dostęp do strony internetowej oraz deinstalację programu.

Instalator programu Hartley występuje w trzech odmianach. Oprócz wersji instalacyjnej opisanej powyżej istnieją również wersje: Hartley_demo oraz Hartley_uakt. Po zainstalowaniu i uruchomieniu programu, w dowolnej zakładce okienka dialogowego, można uruchomić przycisk O programie, który powoduje uruchomienie okienka pokazanego poniżej. Wersja Demo ma wygaszone pole Sprawdź uaktualnienie a pozostałe elementy okienka są identyczne w każdej wersji programu.

Wybranie przycisku Co nowego pozwala na zapoznanie się z nowo wprowadzonymi zmianami do tej wersji.

Jeśli pole Sprawdź uaktualnienie zostało zaznaczone i naciśnięty został przycisk Kontynuuj wówczas rozpoczyna się proces aktualizacji programu z serwera. Należy dalej postępować według pojawiających się wskazówek.

Jeśli wersja używana jest aktualna, to pojawi się odpowiedni komunikat.

Korzystając z okienka O programie można również odwiedzić stronę internetową programu.


Opis opcji

Po uruchomieniu programu na ekranie pokazuje się okienko dialogowe, jak poniżej. Okienko to składa się z kilku części i zawiera w sobie prawie całą funkcjonalność programu. Na górze jest umieszczony krótki opis planu, pod którym znajdują się zakładki: Czynniki, Matryca planu, Interpretacja graficzna, Wyniki pomiarów, Obliczenia, Wykresy oraz Optymalizacja. Przełączanie zakładek, poprzez kliknięcie lewym klawiszem myszki lub klawiszami strzałek (w prawo, w lewo) na klawiaturze, powoduje zmianę zawartości głównej, wewnętrznej części okienka dialogowego.

Program jest przygotowany do pracy z różnymi planami Hartleya i aktualnie obsługuje plany: PS/DS-P:Ha3 i PS/DS-P:Ha4. Zmienne są nie tylko ilości czynników wejściowych ale również ilości powtórzeń pomiarów. Zmiana planu odbywa się poprzez zmianę ilości czynników wejściowych (pole wyboru ilości czynników wejściowych w zakładce Czynniki) lub automatycznie poprzez wczytanie danych z pliku. Poniżej pokazano wersję planu PS/DS-P:Ha4.

Na samym dole okienka znajdują się cztery przyciski, które są zawsze obecne ale mogą nie być aktywne oraz w zależności od sytuacji mają różne opisy i znaczenie. Będą one szczegółowo omówione w przypadku każdej z zakładek. Po prawej stronie okienka, na dole znajduje się przycisk Pomoc. Przycisk ten dostępny jest zawsze i jego użycie powoduje wyświetlenie pomocy kontekstowej czyli zależnej od wybranego typu zakładki.

Poniżej przycisku Pomoc umieszczony jest przycisk O programie, który powoduje uruchomienie okienka pokazanego poniżej a jego funkcje zostały opisane w poprzednim rozdziale Instalacja.

Wybierając poniższe linki można przejść do opisów poszczególnych zakładek.

Czynniki

Matryca planu

Interpretacja graficzna

Wyniki pomiarów

Obliczenia

Wykresy

Optymalizacja


Czynniki

Opis opcji ››

Zakładka Czynniki służy do wprowadzania danych dotyczących parametrów czynników wejściowych oraz czynnika wynikowego. Na początku wszystkie pola edycyjne są puste:

Pola w kolorze białym należy wypełnić ręcznie lub wkleić do nich zawartość skopiowaną wcześniej z innego źródła. Pola liczbowe pozwalają na używanie tylko cyfr i znaku kropki dziesiętnej. Uwaga ta dotyczy pól liczbowych w całym programie.

Druga, dolna część okienka 'Kodowanie czynników' wypełniana jest automatycznie, podczas wpisywania danych w części pierwszej, jak pokazano poniżej, dla przypadku czterech czynników wejściowych.

Po wypełnieniu wszystkich pól zakładka Czynniki wygląda następująco:

W tej opcji opcji aktywne są trzy przyciski na dole okienka: Wczytaj, Wyczyść oraz Zakończ. Przycisk Zakończ powoduje wyjścia z programu a przycisk Wyczyść likwiduje zawartość pól edycyjnych - pola są gotowe do ponownego wpisywania. Natomiast przycisk Wczytaj pozwala na automatyczne wprowadzenie danych o czynnikach, z wcześniej zapisanego pliku z danymi lub wynikami obliczeń.

Przyjęto zasadę, że każdy plik z zapisanymi danymi (zakładka Wyniki pomiarów) lub plik z wynikami obliczeń (zakładka Obliczenia), może być również punktem startowym do kolejnych obliczeń.


Matryca planu

Opcja Matryca planu zawiera tablicę prezentującą plan statyczny, zdeterminowany Hartleya o 3 poziomach zmienności. Znak '+' oznacza wartość maksymalną, znak '-' wartość minimalną a '0' wartość średnią. Kolejne wiersze matrycy można zobaczyć przesuwając suwak po prawej stronie okienka dialogowego. W tej zakładce dostępny jest tylko przycisk Zakończ oraz Pomoc.

Poniżej przedstawiono plan Hartleya dla 4 czynników wejściowych:

oraz dla 3 czynników wejściowych [1].


Interpretacja graficzna

W zakładce Interpretacja graficzna może być umieszczona graficzna prezentacja planu Hartleya, jeśli jest dostępna. Opcja ta nie wymaga od użytkownika jakiejkolwiek reakcji i służy tylko jak ilustracja planu. Dostępne są tylko przyciski Zakończ oraz Pomoc.


Wyniki pomiarów

Opcja Wyniki pomiarów pozwala na wprowadzenie wyników uzyskanych w pomiarach. Istnieje kilka wariantów okienek pomiarowych, w zależności od ilości powtórzeń pomiarów, którą wybiera się w polu wyboru liczba powtórzeń pomiarów. Na rysunku poniżej przedstawiono przypadek dla liczby powtórzeń pomiarów równej dwa.

Dla przypadku trzech powtórzeń pomiarów okienko dialogowe wygląda jak poniżej:

a dla czterech powtórzeń mamy:

Część kolumn, w każdym z okienek, ma pola edytowalne służące do wprowadzania wartości pomiarowych a część, w kolorze szarym, jest tylko do odczytu. Podczas wprowadzania danych pomiarowych pola w odcieniu szarym, w kolumnach 'ysr' - wartość średnia i 'S^2(y)i' - wariancja, wypełniane są automatycznie, na bieżąco. Kolumny do wprowadzania danych można również wypełniać poprzez wklejenie danych do poszczególnych pól, wklejenie całej kolumny lub wklejenie równocześnie wszystkich kolumn.

Jeśli w pierwszej zakładce Czynniki zostanie użyty przycisk Wczytaj, to dane czynników i wyniki pomiarowe zostaną wczytane z pliku i wypełnią odpowiednie pola w obu zakładkach. Przykładowo zakładka Wyniki pomiarów może wyglądać następująco:

Kolumna 'yreg' wypełniana jest automatycznie, po wykonaniu obliczeń w następnej zakładce Obliczenia. Kolumna ta zawiera wartości funkcji regresji dla kolejnych zestawów wartości czynników wejściowych.

W opcji Wyniki pomiarów można również zapisać dane dotyczące czynników oraz pomiarowe do pliku, korzystając z przycisku Zapisz.

Można wybrać dowolny folder zapisu oraz nazwę pliku z rozszerzeniem *.txt. Początkowo zgłasza się folder instalacji programu Hartley i oczywiście można z niego skorzystać. Jeżeli dane do obliczeń wczytano z pliku, to program wstępnie wybiera nazwę tego pliku. Nazwę ją zmodyfikować i zapisać wyniki pod nową nazwą. Jeśli się tego nie zrobi wówczas pojawi się ostrzeżenie o możliwości nadpisania pliku.


Obliczenia

W programie podstawowe obliczenia wykonywane są w zakładce Obliczenia. Po wejściu do tej zakładki, główna część okienka dialogowego jest pusta a dostępne są, oprócz przycisku Pomoc, O programie, tylko przyciski Oblicz oraz Zakończ.

Po uruchomieniu przycisku Oblicz, jeżeli zakładka Czynniki nie była kompletnie wypełniona, wówczas pojawia się komunikat, jak poniżej:

W przypadku nie do końca wypełnionej zakładki Wyniki pomiarów, również pojawia się odpowiedni komunikat.

Użycie przycisku Oblicz uruchamia obliczenia, w których efektem końcowym jest odkodowana funkcja regresji. W trakcie obliczeń wykonywane są między innymi następujące kroki:

- test powtarzalności doświadczenia (statystyka Cochrana)

- wyznaczenie współczynników równania regresji

- ocena istotności współczynników regresji (test t-Studenta)

- generacja ostatecznej, zakodowanej postaci równania regresji

- ocena adekwatności równania regresji (test Fishera)

- odkodowanie równania regresji

Jeśli na którymś z etapów obliczeń pojawią się problemy, wówczas wypisywane są odpowiednie komunikaty. Na przykład poniższy komunikat sygnalizuje brak spełnienia testu powtarzalności doświadczenia:

a kolejny komunikat mówi o braku adekwatności równania regresji:

Po zakończeniu obliczeń, wyniki zostają wyświetlone w okienku dialogowym. Pierwsza część wyników zawiera dane czynników i dane pomiarowe:

a w dalszej kolejności wyświetlane są wyniki następnych kroków obliczeń. W celu przeglądnięcia całości należy skorzystać z pasków przewijania, w pionie i poziomie, znajdujących się w okienku dialogowym.

Wyniki obliczeń wraz z danymi można zapisać do pliku, korzystając z przycisku Zapisz.

Plik z wynikami można przeglądać w dowolnej chwili korzystając na przykład z systemowego notatnika.

Można również w drugiej części pliku (Wyniki obliczeń) wprowadzać zmiany edycyjne, jeśli taka potrzeba wystąpi. W pierwszej części wyników (Dane) nie powinno się dokonywać modyfikacji, ponieważ jest wykorzystywana do wczytywania danych do kolejnych obliczeń.

W opcji Obliczenia, użycie przycisku Drukuj powoduje wydruk wyników na drukarkę. Wydruk będzie realizowany na wybranej w systemie drukarce lub w przypadku jej braku do pliku *.xps (na przykład w Windows'7 i nowszych systemach). Plik ten można wydrukować później na dowolnej drukarce.

Jeśli drukarka jest podłączona do komputera lub dostępna poprzez sieć LAN, można użyć kolejnych okienek do szczegółowych ustawień drukarki (na przykład wydruk w pionie, poziomie, zmiana rozdzielczości itd.).

Poniżej pokazano jeszcze jedno standardowe okienko konfiguracji wydruku.


Wykresy

W zakładce Wykresy można generować wykresy w dwóch wariantach:

- 3D (funkcja regresji zależna od dwóch zmiennych, przy ustalonych pozostałych zmiennych)

- 2D (funkcja regresji zależna od jednej zmiennej, przy ustalonych pozostałych zmiennych)

Jest to możliwe po wykonaniu obliczeń. Przełączenie na zakładkę wykresy uaktywnia okienko 'Konfiguracja funkcji regresji', w którym istnieje możliwość wyboru: typu wykresu, różnych postaci funkcji regresji oraz wartości parametrów. Dodatkowo zawartość tego okienka zależna jest od ilości czynników wejściowych.

Początkowo wybrana jest funkcji regresji, w której zmienne niezależne to pierwsze dwa czynniki wejściowe a parametrami są trzeci i czwarty czynnik wejściowy (dla przypadku 3 czynników wejściowych, tylko trzeci czynnik wejściowy). Po użyciu przycisku Zatwierdź pojawi się wykres przestrzenny funkcji. Opisy wykresu są zgodne z oznaczeniami czynników wejściowych i czynnika wynikowego, podobnie rzecz ma się z jednostkami.

Jeśli w okienku 'Konfiguracja funkcji regresji' zostałaby wybrana zakładka 2D,

to po użyciu przycisku Zatwierdź, na ekranie pojawi się nowy wykres.

Jeśli przykładowo wybierzemy drugą postać funkcji regresji, to otrzymamy poniższy rysunek:

Zmiana wykresu odbywa się poprzez naciśnięcie przycisku Wykres i modyfikacje w okienku 'Konfiguracja funkcji regresji'.

Okienko to można przesunąć na bok aby odsłonić wykres. Wybrane położenie okienka jest zapamiętywane i okienko ponownie wywołane, poprzez użycie przycisku Wykres, pojawia się w tym samym miejscu. Wybranie nowej postaci funkcji regresji zmienia opis parametrów i zestaw dostępnych wartości.

Po wciśnięciu przycisku Zatwierdź, w okienku rysowana jest nowa funkcja.

Dla przypadku trzech czynników wejściowych program zachowuje się bardzo podobnie.

Można również zmieniać wartości parametru jak pokazano na poniższym rysunku:

Jeśli wpisze się wartość parametru (jest to możliwe) spoza zakresu dostępnego dla danego czynnika wejściowego, wówczas program ostrzega o tym ale pozwala narysować funkcję. Na przykład czynnik 'P' na poniższym rysunku może się zmieniać w zakresie 60-160, jeżeli wpisze się wartość 220 i zatwierdzi, to na ekranie pokaże się komunikat:

ale funkcja zostanie narysowana. Część wykresu przekracza maksymalną wartość czynnika wynikowego.

W okienku 'Konfiguracja funkcji regresji' znajduje się również pole zaznaczania 'Pytaj ponownie'. Jeśli jest ono zaznaczone, to każda zmiana zakładki i powrót do zakładki Wykresy, uruchamia ponownie okienko konfiguracji. W przeciwnym wypadku przejście na zakładkę Wykresy powoduje że jest wyświetlany ostatni wykres.

Każdy wykres można zapisać na dysku w postaci pliku, typu *.bmp, korzystając z przycisku Zapisz

lub wydrukować go na drukarce podpiętej do komputera albo dostępnej poprzez sieć LAN. Plik ten można również otwierać i drukować innymi programami, dostępnymi w systemie:

Podobnie jak dla wykresu 3D można zapisać na dysku wykres typu 2D (w postaci pliku, typu *.bmp)

lub wydrukować go na drukarce podpiętej do komputera albo dostępnej poprzez sieć LAN.


Optymalizacja

Program pozwala również na optymalizację, uzyskanej w obliczeniach, funkcji regresji a służy do tego celu zakładka Optymalizacja. Składa się ona z czterech części: szukaj, wartość funkcji, wybierz punkt startowy oraz punkt optymalny. Obszar szukaj pozwala na wybór typu obliczeń: poszukiwanie minimum funkcji lub maksimum funkcji. Po prawej stronie znajduje się wydzielony fragment wartość funkcji. Zawiera on dwa pola, w których wyświetlane są wartość początkowa funkcji oraz wartość końcowa (po optymalizacji). Przy pierwszym wejściu na zakładkę Optymalizacja, wyliczana jest początkowa wartość funkcji dla punktu startowego wyznaczonego jako średnia z minimum i maksimum wartości czynników.

W części wybierz punkt startowy wyświetlane są wartości graniczne (ograniczenia) dla poszczególnych czynników, zadane w zakładce Czynniki oraz wartości punktu startowego, które można zmieniać. Ostatnia część to punkt optymalny, w którym pojawiają się optymalne wartości czynników.

Obliczenia optymalizacyjne rozpoczyna się przyciskiem Uruchom. Program poszukuje optymalnych wartości czynników, które minimalizują lub maksymalizują funkcję regresji w obszarze dopuszczalnym. Poniżej pokazano efekt poszukiwań minimum funkcji dla czterech czynników.

Każda zmiana typu obliczeń powoduje usunięcie zawartości pola 'wartość funkcji końcowa' oraz pól z obszaru punkt optymalny.

Ponowne naciśnięcie przycisku Uruchom, po wybraniu opcji obliczeń maksimum funkcji, uruchamia kolejny cykl obliczeń.

Program kontroluje zadawane wartości punktu startowego. Jeśli na przykład, jak pokazano poniżej, wprowadzona zostanie zbyt duża wartość pierwszego czynnika (przekracza wartość maksymalną równą 160), wówczas program sygnalizuje ten fakt poprzez zmianę koloru naruszonego ograniczenia.

Można uruchomić optymalizację i prawdopodobnie program znajdzie najlepsze rozwiązanie. Będzie to jednak rozwiązanie z obszaru dopuszczalnego. W takim przypadku może się zdarzyć, że wartość początkowa będzie większa od końcowej ale odpowiada ona punktowi startowemu znajdującemu się poza obszarem dopuszczalnym.

Podobnie rzecz się ma w przypadku wyznaczenia minimum funkcji. Tutaj wartość końcowa jest mniejsza od początkowej ale punkt startowy jest poza obszarem dopuszczalnym a wyliczony punkt optymalny jest w granicach obszaru dopuszczalnego.


Informacje dodatkowe

Historia programu

Kontakt


Historia programu

Informacje dodatkowe ››

Poniżej przedstawiono najważniejsze zmiany wprowadzane w kolejnych wersjach programu 'Hartley':

Hartley wer.1.0 2015.02

Hartley wer.1.1 2018.06:

  • nowa opcja 'Optymalizacja' - możliwość wyznaczania minimum i maksimum funkcji regresji
  • nowy przycisk 'O programie' zawierający informacje o programie, dostęp do aktualizacji programu i do strony programu
  • wprowadzono kontrolę poprawności wpisywania danych
  • poprawiono zapis do plików oraz sposób wydruku
  • udostępniono możliwość automatycznej aktualizacji programu lub na żądanie
  • wprowadzono stronę internetową programu
  • uaktualniono pomoc programu

Hartley wer.1.2 2019.02:

  • w opcji wykresy możliwość prezentacji funkcji regresji w dwóch wariantach:

- 3D (funkcja regresji zależna od dwóch zmiennych, przy ustalonych pozostałych zmiennych)

- 2D (funkcja regresji zależna od jednej zmiennej, przy ustalonych pozostałych zmiennych)

  • rozbudowa pomocy programu

Hartley wer.1.3 2023.04:

  • zmiana precyzji wyświetlania wartości zmiennych i parametrów
  • nowa, responsywna strona internetowa
  • możliwość obliczeń poprzez stronę internetową dla przypadku planu Hartleya, dla 3 czynników wejściowych i liczby powtórzeń 2
  • uaktualnienie pomocy programu


Kontakt

Informacje dodatkowe ››

Marek Martyna

email: mm@plany.programy-mm.pl